Where can I download the MOTOTRBO CPS?

The Customer Programming Software required to configure a MOTOTRBO radio is only available to Motorola Channel Partners, who in terms of their agreement with Motorola Solutions, have access to Motorola Online. This is the case for all customers in Europe; the Middle-East and Africa (EMEA).

I understand that in the USA and Canada, it is possible for end-customers to gain access to Motorola Online by purchasing a software subscription licence - this is not available in EMEA. I don't know about Latin America or Asia.

End customers in EMEA can obtain the CPS from the same source as their radios. The radio supplier can, as a service, provide periodic updates for purchased CPS via their website or via Motorola Online. If you need to get the CPS and, for whatever reason, are unable to contact the company who supplied you the radios, then please click here.

If you came here via a Google search, I'm sorry to disappoint you, but it is not possible to download the CPS from this site. Please click here to obtain a legal copy.

14 comments:

  1. Hello Prof. i have problem when i connect radio DP4600e with PC i cannot read radio, CPS show this message. ( Error #1687 unable to detect applicable device (s) check to see if a compatible programming cable is used . please i want solved for it, with thanks.

    ReplyDelete
    Replies
    1. tengo el mismo problema, cual fue tu solucuiĆ³n?

      Delete
  2. Please i want solve for this problem

    ReplyDelete
  3. I have the same problem, what do you doing for this case?

    ReplyDelete
  4. There are three possible causes for error 1687:

    1. The radio
    2. The programming cable
    3. The PC

    To eliminate the PC and programming cable, check to see if this occurs on another radio? If you can program another radio using the same PC; cable and USB port, then the problem is with the radio.
    If not, check the cable and if possible, try another cable.
    Also listen for the Device add sound in Windows - this tells you that the cable is okay and the driver is being loaded.

    ReplyDelete
    Replies
    1. Wrong. The radio is composed from hardware and firmware. The CPS can program any radio model mentioned in the section "ABOUT" and it can program any firmware older than its release date. If the firmware is newer than the CPS you have an incompatibility. For that you need a CPS newer than the firmware's release date.

      Delete
    2. If the CPS was too old, it would give the "...version not supported..." error. Error 1687 is caused by no acknowledge.

      Delete
  5. Hello, can I convert an europe mototrbo ctb file to my LACR radio, my radio is a mototrbo dgp6150. or I have to editing my lacr ctb file with that information. THX

    ReplyDelete
    Replies
    1. No, you will have to recreate the codeplug using the LACR CPS.

      Delete
  6. Thx a lot. Another question Sir

    CPS v14.0 build 738 LACR
    tuner v14.0 build 226
    Firmware

    this software will update/upgrade my mototrbo dgp6150+ LACR radio ?
    thx

    ReplyDelete
    Replies
    1. Yes. Though you don't need the Tuner to carry out the upgrade: this is done in the CPS. You'll need the latest upgrade package though.

      Delete
  7. Holmes Wayne, thanks for your reply.

    ReplyDelete
  8. sir, if error #1057 region not support, its mean what??

    ReplyDelete
    Replies
    1. See https://cwh050.blogspot.de/2013/08/mototrbo-newbie-questions-about.html

      Delete

Powered by Blogger.